apache中配置php后,无法启动php php的版本是:5.2.17
配置文件代码:
LoadModule php5_module d:/php/php5apache2_2.dll AddType application/x-httpd-php.php PHPIniDir "d:/php"下载的是压缩包,安装在d:/php出现状况:the requested operation has failed怎么解决呢?
Apache PHP PHP5压缩web
分享到:
------解决方案--------------------引用:Apache is running a threaded MPM, but your PHP Module is not compiled to be threadsafe. You need to recompile PHP. Pre-configuration failed
主要是这句,参考一下:
http://blog.csdn.net/abandonship/article/details/7344918------解决方案--------------------新手的话建议你安装个wamp,特别好用,我就是新手。
------解决方案--------------------是的,要打开php.ini文件,修改。
extension_dir 应该不需要修改,默认安装时已经设置default_charset可以换成你需要的。
extension则是找到你想要的,删掉前面的分号;修改完保存并重启apache(管理工具->服务 找到apache2)。
你所说的“安装不成功”是指什么现象?
------解决方案--------------------我按照韩顺平php视频特意安装了下,安装成功后,对照了下楼主的安装情况,指出不一样。
1.apache 的配置文件,httpd.conf,韩顺平老师配置这么进行配置的(可忽略路径的不同);
PHPIniDir "F:/ampserver/php"LoadModule php5_module f:/ampserver/php/php5apache2_2.dll SetHandler application/x-httpd-php 2.接下来,我们要进行的是php的安装。php解压缩后,并没有php.ini这个文件,你所要做的,是要将php.ini-production修改成php.ini(这步是不是没做?).
3.在apache的htdoc文件里,你最好放置一个文件可命名为info.php 该文件就是php
3.你后面的问题:
打开php.ini文件:(添加或打开) extension_dir = "PHP安装目录\ext"default_charset = "gbk"extension=php_mysql.dll不明白怎么改,因为这些php.ini的修改主要是针对的是mysql的安装。实现php和mysql接通。
更详细的还是建议你看看韩顺平的php视频教程第25讲-30讲。
