跳转到主内容
极星编程网:以代码为星,赴技术山海!

php如何解决过多的重定向

由于项目需要,以前使用apache作为服务器的项目需要改换成nginx,但是换过之后出现了一个问题,直接使用域名进行访问的时候提示“该网页无法正常运作 重定向的次数过多 err_too_many_redirects”。 通过一步一步对代码进行断点输出查到原因是没有进行设置默认的访问模块(默认控制器和默认方法)或者设置的默认访问模块(默认控制器和默认方法)不存在。所以造成了此种原因。 解决方案如下: (推荐学习: PHP视频教程 ) 首页直接配置跳转向 admin. php ,但由于\thinkphp\library\think\Request.php文件中中,pathinfo() 函数 return $this->pathinfo; PHP 8.5.5 PHP 8.5.5 是 PHP 8.5 分支的维护更新版本。该版本延续了“小步快跑”的迭代逻辑,通过深度错误修复、底层性能微调以及安全加固,旨在为开发者提供一个更健壮、更高效的运行环境。该版本严格遵守语义化版本规范,不包含破坏性变更。 下载 立即学习 “ PHP免费学习笔记(深入) ”; 结果为'/',,这种情况就会去配置文件中查找设置默认的控制器和操作,由于未进行这只默认的访问模块和控制器以及方法,所以造成“重定向的次数过多”错误返回。 我们只需将 tp5 中 \application\config.php配置文件中的default_module(默认模块名)配置default_controller(默认控制器名)配置和default_action(默认操作方法名)配置改成存在的控制器和方法就行:
// 默认模块名 'default_module' => 'home', // 默认控制器名 'default_controller' => 'Index', // 默认操作名 'default_action' => 'index',

相关文章